Resolved
Payments are now linked to insurance estimates
Identified
We've identified the issue and have a solution. We're deploying the fix in the next 15 mins.
Investigating
Payments are not linking to insurance estimates after being processed. We're actively investigating. The current workaround is to create the payment manually. GFE estimates are functioning as expected.